Advanced Android-x86 Installer For Windows

Software Advanced Android-x86 Installer For Windows v1.8

AXON

Supreme
Moderator
Blog Author
Introduction

Advanced Android-x86 Installer is an windows executable which can help you install possibly any android-x86 operating system directly from windows. It also helps you in installing multiple clones of the same operating system and multi-booting them. Not only that, you can also directly pre-install latest GearLock while installing an android-x86 OS with it.

Feature Highlights
  • Additional Ext2/3/4 partition support directly from windows.

  • Supports both Legacy and uEFi BIOS.

  • Ability to directly install latest GearLock during OS installation.

  • Built-in partitioning program to manage/create partitions from windows for you OS.

  • Install/create multiple instances/clones of the same/different OS and multi-boot them.

  • Can create up to 32BG sized data.img.

Video Tutorial

If you are having difficulties with understanding what and how to do then check this out.


Tested With
  • BlissOS
  • PrimeOS
  • RemixOS
  • PhoenixOS
  • LineageOS
  • Official Android-x86
Note: It will likely do fine with almost anything newer/older.

For Developers

If you are interested in to include this installer with your android-x86 operating system .ISO's then you can refer to the repo below to learn more.

Common Issues

Here I'm listing some of the common issues which are mainly over grub2win and extFS.
  • Can't find grub2win on boot over a uEFI BIOS.
    --->>>> It's because sometimes Windows takes over grub2win.
    --->>>> So, boot from your BIOS boot menu, you will find grub2win there.

  • Getting error while grub2win installation
    --->>>> Most likely your boot partition is a bit messed up.
    --->>>> Try to revert any modifications made from softwares like EasyBCD, EasyUEFI etc.

  • Files failed to install over extFS installation option
    --->>>> Sometimes the installer fails to mount your Ext2/3/4 filesystems as read and write, thus it gets mounted as read-only and it remains in panic-mode.
    --->>>> The only solution to resolve this issue is to RESTART windows and then following the same installation process, but that time skip partitioning since you've already done that.

Thanks To

This installer relies on some external programs to enrich itself, without them it wouldn't have been cool enough.
  • David Pickens for his Grub2Win. (Used as the bootloader for multi-booting)
  • Igor Pavlov for 7-zip. (Used for reading ISO files)
  • @DiskGenius Eassos Ltd for their Free-Partition-Manager. (Used as the partition-tool)
Also special thanks to the early-beta testers: @Night, @Ahmad Moemen, @PAIN
 
Last edited:

pitrako

New member
VC
8
I installed bliss os, when selecting the entry in grub2win and booting with the first option It shows "_" and then reboots, how can I solve this?

EDIT: My card, cpu and the version of bliss os are:
- RTX 2080
- I7-9700K
- Blis OS 11.13
 
Last edited:

AXON

Supreme
Moderator
Blog Author
I installed bliss os, when selecting the entry in grub2win and booting with the first option It shows "_" and then reboots, how can I solve this?

EDIT: My card, cpu and the version of bliss os are:
- RTX 2080
- I7-9700K
- Blis OS 11.13
  1. Did you install on NTFS/EXT4?
  2. What is your BIOS structure? (Legacy/uEFi)
  3. Provide a screenshot of where you installed the operating-system.
 

pitrako

New member
VC
8
- Did you install on NTFS/EXT4?
Recommended option, extFS.

- What is your BIOS structure? (Legacy/uEFi)
uEFI but I disabled secure boot.

- Provide a screenshot of where you installed the operating-system.
1-
Sin-t-tulo.jpg

2-
Sin-t-tulo2.jpg

3-
Sin-t-tulo3.jpg

4-
Sin-t-tulo4.jpg

5-
Sin-t-tulo5.jpg

6-
Sin-t-tulo6.jpg

7-
Sin-t-tulo7.jpg

8-
IMG-20210324-115308.jpg

9-
IMG-20210324-115348.jpg

Then I get a black screen or underscore and autoreboots.
EDITED: I solved my problem by reseting bios defaults, now doesn't autoreboots but bliss os 14 is stuck at "system.img has been successfully extended to 5010MB".
 
Last edited:

pitrako

New member
VC
8
It's a desktop MSI pre-built PC (9SE-297EU), the tooI installed bliss os pie correctly but It shows distorted image (I suppose RTX cards are not supported) and I tried to install bliss os 14 in hopes of better hardware compatibility (AG-11-Bliss_OS-14-x86_64-202012190914_kernel-5.8-si-next-fs_r_egapps_libndk_wv_m.iso) but It's stuck at "system.img has been successfully extended to 5010MB".
 

AXON

Supreme
Moderator
Blog Author
but It's stuck at "system.img has been successfully extended to 5010MB".
Basically, this is the part where GearLock is done doing it's job. As you said that the process got stuck after this message means that it switched into /android which probably failed to deal with your GPU and crashed ...

I don't know about your GPU configuration... so the author of blissOS @Electrikjesus or @HMTheBoy154 / @Night can help I hope.
 

Night

Supreme
Moderator
Blog Author
It's a desktop MSI pre-built PC (9SE-297EU), the tooI installed bliss os pie correctly but It shows distorted image (I suppose RTX cards are not supported) and I tried to install bliss os 14 in hopes of better hardware compatibility (AG-11-Bliss_OS-14-x86_64-202012190914_kernel-5.8-si-next-fs_r_egapps_libndk_wv_m.iso) but It's stuck at "system.img has been successfully extended to 5010MB".
support for your nvidia GPU is not present in any android x86 but you can use your intel iGPU to run games.

you can check this video for more info

 

pitrako

New member
VC
8
I enabled in my bios "IGD Multi-Monitor", that's supposed to activate the integrated intel graphics at the same time as the dedicated GPU is working, I tested It inside windows 10 and now lists the two, but how I force bliss os 11.13 to run iGPU only?, I have to add some parameter to the grub (I'm using the grub2win that "advanced android-x86 installer" downloads)? I tried EXTMOD=i915 but I don't know where exactly to put It because does not work.
 

AXON

Supreme
Moderator
Blog Author
I enabled in my bios "IGD Multi-Monitor", that's supposed to activate the integrated intel graphics at the same time as the dedicated GPU is working, I tested It inside windows 10 and now lists the two, but how I force bliss os 11.13 to run iGPU only?, I have to add some parameter to the grub (I'm using the grub2win that "advanced android-x86 installer" downloads)? I tried EXTMOD=i915 but I don't know where exactly to put It because does not work.
I'm not entirely sure but you should just enforce the use of a single GPU(intel) instead of that dual IGD Multi-Monitor thingy for android-x86 purposes if possible .. or maybe even unplug your dedicated GPU wire 😂. Other than that, I ain't got any more ideas for you.
 

Similar threads

Similar threads

Get Connected

Discord Server

New Threads

Top