Help Can't use full CPU frequency, locked at 0.79GHZ

3OMDA

New member
VC
36
I cant use my full cpu clock i tried unlock frequency but nothing change in ,
Screenshot_20210708-153838.jpg


btw in windows i just use throttlestop and disable bd prochot
here bdprochot enabled
1625759766596.png

and here bd prochot disabled
1625759882967.png

i am doing this every time i start my pc so i wonder if this fonction avaible in pheonix os and if not Is there any other way ?????
 
Solution
He use stock kernel, so idk if msr exist, but mitigations off is not needed

maybe type modprobe msr and then dump the stuff again
i figured it out , i searched in google about msr tool and i found this
Screenshot_20210709-214951.jpg

its all about odd numbers and even numbers he just wrote 2 after wrmsr 0x1FC and its worked
writing an even number after wrmsr 0x1FC disabel bdprochot




Screenshot_20210709-214617.jpg


writing an odd number after wrmsr 0x1FC enable bd prochot
Screenshot_20210709-214642.jpg


so to check...

Xtr

Active member
in our Discord server there used to be a guide to hack it using msr-tool
Check it on pinned note or ask anyone to bring that post up
This is the note:
msr-tools

• Extract msr-tools-test-3.zip • Copy wrmsr, rdmsr and cpuid to /system/bin • Open terminal using alt+f1 or alt+f8 • Run the following commands: chmod a+x /system/bin/cpuid
chmod a+x /system/bin/rdmsr
chmod a+x /system/bin/wrmsr
• To disable cpu throttling (BD prochot flag) modprobe msr
rdmsr -d 0x1FC
• Whatever the value you get you need to substract one and use it with this command.

For example if you get 2587321 -1
wrmsr 0x1FC 2587320
• To disable intel turbo boost wrmsr 0x1a0 0x4000850089
• If this worked for you you can put it in a script to make it happen on boot.

How ? • Make a script as /[system] [data]/ghome/gearboot/boot-comp/msr.sh • Write inside it
modeprobe msr
wrmsr 0x1FC yourvalue

Note: You don't have to manually make it executable, it doesn't matter for gearboot
 

3OMDA

New member
VC
36
it didnt work i tried it with normal boot and unlock frequency boot and nothing happend any other ideas ? also does enabling/disabling intel speedstep in bios matter ???
 

AXON

Supreme
Moderator
Blog Author
it didnt work i tried it with normal boot and unlock frequency boot and nothing happend any other ideas ? also does enabling/disabling intel speedstep in bios matter ???
Provide geardump, lemme see your cmdline
 

3OMDA

New member
VC
36
Provide geardump, lemme see your cmdline
Post automatically merged:

unlock frequency boot ? What are you using ? AOS ?
i was using posrog os but i switched to darkmatter now and i tried the method again and didnt work 😢
 

Attachments

  • geardump.zip
    1.8 MB · Views: 4
Last edited:

HMTheBoy154

Supreme
Moderator
Blog Author
Post automatically merged:


i was using posrog os but i switched to darkmatter now and i tried the method again and didnt work 😢
ok which command did you type on terminal to fix that problem ?
I need you to type everything that you type on it to fix this bd prochot, so I can see what you were wrong
 

3OMDA

New member
VC
36
ok which command did you type on terminal to fix that problem ?
I need you to type everything that you type on it to fix this bd prochot, so I can see what you were wrong
i type it exactly [the methode didnt work in both system posrog and darkmatter i thinked maybe you misunderstand my last reply because my english little poor 😅]
 

Attachments

  • a9511a36bd267418714b91e1cbb29fb5.0.jpg
    a9511a36bd267418714b91e1cbb29fb5.0.jpg
    38.4 KB · Views: 9
Last edited:

Similar threads

Similar threads

Get Connected

Discord Server

New Threads

Latest From Blog

Top