Showcase Clash Royale working in DarkMatter!

dabombUSA

New member
Supercell dropped suport for x86 devices in their End of September Update (30/9/19) Quote "Clash Royale no longer supports Android devices with a x86 processor".

I and countless others where sad and mad that they took all of us by surprise and did this without any warning whatsoever. The game just lags and is almost unplayable on any android phone or tablet so playing it on an x86 OS was the best expierience to play this game on a big screen and lag free. I was using and playing it on official PrimeOS at that time when it stopped working on it.

Ever since then I was on a mission to find an x86 OS that I could play this game on again. I tried just about every official and mod one out there with no luck. This mission I was on soon led me to DarkMatter where I found not only the best x86 OS I have tried but also a fantastic community that supports it. My search was over I found the perfect x86 OS for me.

After many failed attempts to get Clash Royale working in DarkMatter I gave up on this game and didn't care much about it anymore because I was having such a great expierience with Darkmatter and with all other games I play on it. Just recently I felt a need to want to play this game again so I played arround with different configurations in DarkMatter again and finally found one that works. Yes you heard it right Clash Royale works in DarkMatter!

This is my configuration and the steps I did to get it working. Other configurations may also work but this is what worked for me and may or may not work for you. The only problem I found is that you can't play it full screen or resize the window but it plays perfect and is fast and smooth.

1) Install the latest Exo 4.6 version of Darkmatter.
2) Apply the Unity fix and change the protocol to Delta in gearlock.
3) Install the sakura 1.2 kernel 5.4.30 (I used the non GoogleLTS one).
4) Install the mesa 20.0.2-LLVM8.
5) Install Clash Royale from the Play Store.
6) Open the game and enjoy!

Screenshot_20200407-180514.jpgScreenshot_20200407-181330.jpgScreenshot_20200407-182258.jpgScreenshot_20200408-005630.jpgScreenshot_20200408-030014.jpg
 

golpesar73

New member
VC
4
Hey and tnx for guide

I installed Exo 4.6 version of Darkmatter and apply unity fix in stock gearlock and change the protocol to Delta

but I can't install sakura 1.2 kernel with stock gearlock , it said the file is Corrupted

after i update gearlock it can install that but the game protocol disappear in new versions of gearlock

I continue and install mesa and after launch clash royale it crashed in 50% loading.

Can you help me?
 

Similar threads

Similar threads

Get Connected

Discord Server

New Threads

Latest From Blog

Top