Help Doesn't wake up from sleep after a while of inactivity.

galbotorix

Novice
Jan 4, 2021
4
1
3
bahrain
VC
10
so i can finally use the power button and put the device to sleep but i cant seem to wake it up after some time has passed, and to top it off the battery drain while its sleeping is worse that when its awake.

device im using is an asus t100ta yep hard af machine to do stuff on but a fun challenge.
have kenels 5.10 and 4.19 installed, these are what made the power button work both are google LTS xanmod.
 

İlhan

Novice
Feb 8, 2020
175
43
28
Hatay Turkey
VC
404
More  
Games I Play
PUBG MOBILE, Free Fire, Rules of Survival
so i can finally use the power button and put the device to sleep but i cant seem to wake it up after some time has passed, and to top it off the battery drain while its sleeping is worse that when its awake.

device im using is an asus t100ta yep hard af machine to do stuff on but a fun challenge.
have kenels 5.10 and 4.19 installed, these are what made the power button work both are google LTS xanmod.
Some device works on sleep mode when vulkan activated.(but there is no actual fix)
 
  • Like
Reactions: galbotorix

xtttt

Novice
Jul 27, 2020
86
30
18
Asia
VC
185
so i can finally use the power button and put the device to sleep but i cant seem to wake it up after some time has passed, and to top it off the battery drain while its sleeping is worse that when its awake.

device im using is an asus t100ta yep hard af machine to do stuff on but a fun challenge.
have kenels 5.10 and 4.19 installed, these are what made the power button work both are google LTS xanmod.
Some people first press the power button and then the volume button (on some occasions when it enters sleep mode then it is no longer possible to use the system).
Try tapping the space bar after power button
Not all machines are created equal, you may also try following kernel parameters
  • sleep=1: This will enable the system.prop value for sleep.earlysuspend=1, and on some machines, it enables the proper sleep state.
  • acpi_sleep=s3_bios,s3_mode: Sometimes needed for older machines to enter sleep mode properly
[HW,ACPI] Sleep options
Format: { s3_bios, s3_mode, s3_beep, s4_nohwsig,
old_ordering, nonvs, sci_force_enable, nobl }
See Documentation/power/video.rst for information on
s3_bios and s3_mode.
s3_beep is for debugging; it makes the PC's speaker beep
as soon as the kernel's real-mode entry point is called.
s4_nohwsig prevents ACPI hardware signature from being
used during resume from hibernation.
old_ordering causes the ACPI 1.0 ordering of the _PTS
control method, with respect to putting devices into
low power states, to be enforced (the ACPI 2.0 ordering
of _PTS is used by default).
nonvs prevents the kernel from saving/restoring the
ACPI NVS memory during suspend/hibernation and resume.
sci_force_enable causes the kernel to set SCI_EN directly
on resume from S1/S3 (which is against the ACPI spec,
but some broken systems don't work without it).
nobl causes the internal blacklist of systems known to
behave incorrectly in some ways with respect to system
suspend and resume to be ignored (use wisely).

mem_sleep_default= [SUSPEND] Default system suspend mode:
s2idle - Suspend-To-Idle
shallow - Power-On Suspend or equivalent (if supported)
deep - Suspend-To-RAM or equivalent (if supported)
 

galbotorix

Novice
Jan 4, 2021
4
1
3
bahrain
VC
10
Some people first press the power button and then the volume button (on some occasions when it enters sleep mode then it is no longer possible to use the system).
Try tapping the space bar after power button
Not all machines are created equal, you may also try following kernel parameters
  • sleep=1: This will enable the system.prop value for sleep.earlysuspend=1, and on some machines, it enables the proper sleep state.
  • acpi_sleep=s3_bios,s3_mode: Sometimes needed for older machines to enter sleep mode properly
[HW,ACPI] Sleep options
Format: { s3_bios, s3_mode, s3_beep, s4_nohwsig,
old_ordering, nonvs, sci_force_enable, nobl }
See Documentation/power/video.rst for information on
s3_bios and s3_mode.
s3_beep is for debugging; it makes the PC's speaker beep
as soon as the kernel's real-mode entry point is called.
s4_nohwsig prevents ACPI hardware signature from being
used during resume from hibernation.
old_ordering causes the ACPI 1.0 ordering of the _PTS
control method, with respect to putting devices into
low power states, to be enforced (the ACPI 2.0 ordering
of _PTS is used by default).
nonvs prevents the kernel from saving/restoring the
ACPI NVS memory during suspend/hibernation and resume.
sci_force_enable causes the kernel to set SCI_EN directly
on resume from S1/S3 (which is against the ACPI spec,
but some broken systems don't work without it).
nobl causes the internal blacklist of systems known to
behave incorrectly in some ways with respect to system
suspend and resume to be ignored (use wisely).

mem_sleep_default= [SUSPEND] Default system suspend mode:
s2idle - Suspend-To-Idle
shallow - Power-On Suspend or equivalent (if supported)
deep - Suspend-To-RAM or equivalent (if supported)
alright ill try these this sunday and get back to you
Post automatically merged:

Some people first press the power button and then the volume button (on some occasions when it enters sleep mode then it is no longer possible to use the system).
Try tapping the space bar after power button
Not all machines are created equal, you may also try following kernel parameters
  • sleep=1: This will enable the system.prop value for sleep.earlysuspend=1, and on some machines, it enables the proper sleep state.
  • acpi_sleep=s3_bios,s3_mode: Sometimes needed for older machines to enter sleep mode properly
[HW,ACPI] Sleep options
Format: { s3_bios, s3_mode, s3_beep, s4_nohwsig,
old_ordering, nonvs, sci_force_enable, nobl }
See Documentation/power/video.rst for information on
s3_bios and s3_mode.
s3_beep is for debugging; it makes the PC's speaker beep
as soon as the kernel's real-mode entry point is called.
s4_nohwsig prevents ACPI hardware signature from being
used during resume from hibernation.
old_ordering causes the ACPI 1.0 ordering of the _PTS
control method, with respect to putting devices into
low power states, to be enforced (the ACPI 2.0 ordering
of _PTS is used by default).
nonvs prevents the kernel from saving/restoring the
ACPI NVS memory during suspend/hibernation and resume.
sci_force_enable causes the kernel to set SCI_EN directly
on resume from S1/S3 (which is against the ACPI spec,
but some broken systems don't work without it).
nobl causes the internal blacklist of systems known to
behave incorrectly in some ways with respect to system
suspend and resume to be ignored (use wisely).

mem_sleep_default= [SUSPEND] Default system suspend mode:
s2idle - Suspend-To-Idle
shallow - Power-On Suspend or equivalent (if supported)
deep - Suspend-To-RAM or equivalent (if supported)
well unfortunately that didnt work, im going to try building bliss os and import some kernels and see if that works
 
Last edited:

Get Connected

Discord Server

New Threads

Latest From Blog