How to fix Google play store crashing issues in phoenix os


Hello everyone,
it's been a while since i made a blog post & today i want to make a post about very important issue on phoenix os that has been in the phoenix os from very long.

[ The Problem ]
Phoenix os doesn't allow you to auto install or update google play service so every time play store will try to update it play service it's fail.
the reason for this might be they know that new play service update might break the os since they are not tested by the phoenix os team.

[ The Solution ]

If you are using DM 4.7 or later build this issues will be gone thanks to @HMTheBoy154 for figuring out & patching the problem.

and if you are waiting for DM 4.7 like everyone else then here's a quick way to fix this.

1# Enable google less mode in gearlock.

press ALT+F1 & type gearlock to open it then goto to system/Tweak section & enable googless mode.

Warning :- this will remove goole play store & play service from your Darkmatter.

2# Download play store & play service from apkmirror.

> Download any play store apk by searching on apk mirror.
Link :-


> Download any latest stable play service x86_x64 version download download the beta version.
Link :-



3# Rename the apk files to GMSCore.apk (for play service ) and Phonesky.apk (for play store).

4# Use FX File Manager or paragon in windows and copy the apk files to following location.

Play service :- "/system/priv-app/GmsCore/GMSCore.apk"
Play Store :- "/system/priv-app/Phonesky/Phonesky.apk"

if folder doesn't exist there then just make one.

5# Now just reboot your system & check if you still get that error.


> if you still not getting the play store then make sure to disable google less mode in gearlock.
> Also clear you Dalvik cache using gearlock mode misc section after googless if you still get that crashing erro.
> if issues still not fixed then format your ext4 drive & re install phoenix os.

Thanks, :)