Help how to mount /system as RW

Naphaly

New member
VC
6
i tries to install some kernel on PrimeOS mainline (the original) then it said that /sytem it not writable
then i tries to mount it, similar:
mount -o, remount /system
then it said
system i/o error
i can't run gearlock in terminal affter install MagiskSU (idk did it change from SuperSU or not because i can't open Root permsion anymore), but Alt F1 and Recovery work fine
 
Solution
nah i found the reason by myself
so the PrimeOS had a file system .sfs which can only open at Read-only, so basicaly extract it into system.img , then everythings back they should be ¯\( ͡° ͜ʖ ͡°)
(to prove how dumb i am, i was already fix this before, so when i searching for the solution the link i used before popup make me felt so depression)

Night

Supreme
Moderator
Blog Author
i tries to install some kernel on PrimeOS mainline (the original) then it said that /sytem it not writable
then i tries to mount it, similar:
mount -o, remount /system
then it said
system i/o error
i can't run gearlock in terminal affter install MagiskSU (idk did it change from SuperSU or not because i can't open Root permsion anymore), but Alt F1 and Recovery work fine
you can try using fx file manager app > enable root permissions from it's setting > goto #system directory > click on the lock icon on top right to mount /system as RW.
 
The code has missed its permission type, so it can't be done

mount -o rw,remount /system < to mount as read write
mount -o ro,remount /system < to close read write

and as i recall when installing magisk had to uninstall superSU.
Post automatically merged:

Just make a simple script to call the command mount R/W

This is the command that will be called

#Mount R/W
echo "Enter where the folder is"
read p
mount -o rw,remount $p

save as mt.sh to /system/etc

then make a command to copy the mt.sh to the system folder on every reboot ( put it in init.sh before return 0 )

mount -o rw,remount /
cp -f /system/mt.sh /
chmod 777 /mt.sh
mount -o ro,remount /

to call the script, just command /mt.sh
 
Last edited:

Naphaly

New member
VC
6
nah i found the reason by myself
so the PrimeOS had a file system .sfs which can only open at Read-only, so basicaly extract it into system.img , then everythings back they should be ¯\( ͡° ͜ʖ ͡°)
(to prove how dumb i am, i was already fix this before, so when i searching for the solution the link i used before popup make me felt so depression)
 
Solution

Similar threads

Similar threads

Get Connected

Discord Server

New Threads

Latest From Blog

Top