Help I am facing lag in freefire any solution?

Solution
I am using dm 4.7 i have use the arm protocol also but the game is lagging so much please help me
Actually, you may know the reason since you know about the protocols. We have to wait until the release their next update. I hope they'd release an x86 version next time. Running arm apps on x86 is not a pretty great idea for everyone. But, you can still play with performance issues. If you want to improve a little bit of performance. Follow these steps to slightly improve performance.

Clearing Dalvik Cache
Clearing Dalvik Cache may help your clear out caches and give you a slight boost in games. I suggest you to do in this in an interval of time ( e.g 2 or 3...

Jaxparrow

Well-known member
Moderator
Blog Author
I am using dm 4.7 i have use the arm protocol also but the game is lagging so much please help me
Actually, you may know the reason since you know about the protocols. We have to wait until the release their next update. I hope they'd release an x86 version next time. Running arm apps on x86 is not a pretty great idea for everyone. But, you can still play with performance issues. If you want to improve a little bit of performance. Follow these steps to slightly improve performance.

Clearing Dalvik Cache
Clearing Dalvik Cache may help your clear out caches and give you a slight boost in games. I suggest you to do in this in an interval of time ( e.g 2 or 3 days ).

You can do it by Opening Gearlock > Wipe FS > Dalvik Cache ( /data/dalvik cache )

Removing Resource Pack in Game
As you might now, Free Fire has inbuilt download manager for assets. You can delete the assets in Main Storage > Android > data > com.dts.freefireth.

After deleting the folder, You can download only the Emotes, Skins, Outfits that you use or you want to see. Don't download all the 600MB of resources. This can even cause lags in game.

Google less mode
You can try enabling permanent Google less in Gearlock Settings. This can save you some RAM and will give you some slight performance boost.

Changing Gov/Frequency
You try if the above options doesn't seem to do nothing. You can change your minimum/maximum frequency and the CPU Governor.

Go to Gearlock > Extra Misc. > Change GOV / Freq

You need to go again to the Change GOV / Freq option for each of the option shown above ( min, max, gov )

You can set your maximum frequency to the last option which is supported by your CPU.

Set the Minimum frequency to 2 or 3 options before the last option. If the last option is 25, You can use 23 or 22. Setting the last option will make the CPU work at full potential even if there is no work and can cause overheating and some issues.

Change the CPU governor to performance mode.

When making changes, a prompt will show up and do you want to make changes on boot. Press y and hit enter to save it for boot. So, it will automatically change them when you boot.

As you might think, Yeah.. It took me 10 minutes to write this Bigass post :ROFLMAO:
 
Last edited:
Solution

prabeshpanta

New member
VC
14
Actually, you may know the reason since you know about the protocols. We have to wait until the release their next update. I hope they'd release an x86 version next time. Running arm apps on x86 is not a pretty great idea for everyone. But, you can still play with performance issues. If you want to improve a little bit of performance. Follow these steps to slightly improve performance.

Clearing Dalvik Cache
Clearing Dalvik Cache may help your clear out caches and give you a slight boost in games. I suggest you to do in this in an interval of time ( e.g 2 or 3 days ).

You can do it by Opening Gearlock > Wipe FS > Dalvik Cache ( /data/dalvik cache )

Removing Resource Pack in Game
As you might now, Free Fire has inbuilt download manager for assets. You can delete the assets in Main Storage > Android > data > com.dts.freefireth.

After deleting the folder, You can download only the Emotes, Skins, Outfits that you use or you want to see. Don't download all the 600MB of resources. This can even cause lags in game.

Google less mode
You can try enabling permanent Google less in Gearlock Settings. This can save you some RAM and will give you some slight performance boost.

Changing Gov/Frequency
You try if the above options doesn't seem to do nothing. You can change your minimum/maximum frequency and the CPU Governor.

Go to Gearlock > Extra Misc. > Change GOV / Freq

You need to go again to the Change GOV / Freq option for each of the option shown above ( min, max, gov )

You can set your maximum frequency to the last option which is supported by your CPU.

Set the Minimum frequency to 2 or 3 options before the last option. If the last option is 25, You can use 23 or 22. Setting the last option will make the CPU work at full potential even if there is no work and can cause overheating and some issues.

Change the CPU governor to performance mode.

When making changes, a prompt will show up and do you want to make changes on boot. Press y and hit enter to save it for boot. So, it will automatically change them when you boot.

As you might think, Yeah.. It took me 10 minutes to write this Bigass post :ROFLMAO:
Thanks a lot
me : I can't play freefire now because it is lagging.
Jaxparrow : I am inevitable To freefire lag.

 
Last edited by a moderator:

BhaviGamer

New member
VC
38
Hey, Thanks for your words..
man but when i try to launch free fire on DM 4.7 it crashes . I am using arm-v7a version of free fire
Post automatically merged:

I am using dm 4.7 i have use the arm protocol also but the game is lagging so much please help me
man but when i try to launch free fire on DM 4.7 it crashes . I am using arm-v7a version of free fire
Post automatically merged:

I am using dm 4.7 i have use the arm protocol also but the game is lagging so much please help me
i have a solution fo you
you can try changing OS
Thanos OS is best for low end no lag
join their telegram group
 
Last edited:

prabeshpanta

New member
VC
14
Bro
man but when i try to launch free fire on DM 4.7 it crashes . I am using arm-v7a version of free fire
Post automatically merged:


man but when i try to launch free fire on DM 4.7 it crashes . I am using arm-v7a version of free fire
Post automatically merged:


i have a solution fo you
you can try changing OS
Thanos OS is best for low end no lag
join their telegram group
os is not the problem freefire remove *86 support that why ff lags
 

Jaxparrow

Well-known member
Moderator
Blog Author
pubg dont have x86 support but dont lag in Darkmatter
its your hardware problem brother they are low end
try thanos os lag will fix
Actually, you're not getting what he is telling. They both are different engines. PUBG is Unreal and Free Fire is Unity. Unity's arm support doesn't work great. Also, everyone had played Free Fire with 60FPS are even getting 30~45FPS average. A sudden lag made the game unplayable. Hope free fire would release an x86 version next time.
 

Similar threads

Similar threads

Get Connected

Discord Server

New Threads

Latest From Blog

Top