Help Problems with Gearlock Kernel packages

Yasla

New member
VC
30
Hello,
I have a huge problem with all Kernel packages in the resources section except the stock 4.14.15 POS Kernel. When I install any 4.13.x, 4.14.x and 4.19.x the CPU Load will be at 20-40% even though I'm just at the desktop without any apps open. In PUBG my CPU will get to 80°C at only 2.1GHZ (On stock Kernel PUBG runs at 2.6GHZ and 65°C with less Load).
When I Install the Kernels I mentioned above manually via APT from other sources the CPU Loads work perfectly (0-3% in desktop), but on the Kernels from other sources my Wifi and Bluetooth never even turn on, so I can't use them. On the Gearlock packages my Wifi and Bluetooth works perfectly.
Installing Stock Kernel via Gearlock works without any Problems.
I hope someone can help me with this or give me files to put on the other Kernels to fix my Wifi and Bluetooth problem.
My Device:
Surface Pro 6
i5-8250U
UHD 620

Thanks
 

ilhan

Active member
Hello,
I have a huge problem with all Kernel packages in the resources section except the stock 4.14.15 POS Kernel. When I install any 4.13.x, 4.14.x and 4.19.x the CPU Load will be at 20-40% even though I'm just at the desktop without any apps open. In PUBG my CPU will get to 80°C at only 2.1GHZ (On stock Kernel PUBG runs at 2.6GHZ and 65°C with less Load).
When I Install the Kernels I mentioned above manually via APT from other sources the CPU Loads work perfectly (0-3% in desktop), but on the Kernels from other sources my Wifi and Bluetooth never even turn on, so I can't use them. On the Gearlock packages my Wifi and Bluetooth works perfectly.
Installing Stock Kernel via Gearlock works without any Problems.
I hope someone can help me with this or give me files to put on the other Kernels to fix my Wifi and Bluetooth problem.
My Device:
Surface Pro 6
i5-8250U
UHD 620

Thanks
Off topic but do you know?
You can find kernel for your surface device;

 

Yasla

New member
VC
30
Off topic but do you know?
You can find kernel for your surface device;

Already tried that...same problem happens...CPU has "fake" load permanently for no reason
 

AXON

Supreme
Moderator
Blog Author
Maybe you should try something other than thunderOS (you mentioned about it on the private message with me but why not here? It's not like we won't try and help you if we know that) ....
They applied some cpu-tweaks without any prior knowledge about what they can cause.
 

Yasla

New member
VC
30
I did't mentioned it because I already tried it with DM 4.7, 4.6, Thunder 4.4,4.5 and ROC Instinct III.
So I'm pretty sure it has something to do with the files in the packages which are not 100% compatible with my hardware.
Post automatically merged:

Maybe you should try something other than thunderOS (you mentioned about it on the private message with me but why not here? It's not like we won't try and help you if we know that) ....
They applied some cpu-tweaks without any prior knowledge about what they can cause.
a short-time solution could be to get the wifi and bluetooth related files from modules and Firmware in gxp package and replace it with the one in the other kernel from different source.
Maybe this doesn't make any sense XD...you know it better than me
Post automatically merged:

Maybe you should try something other than thunderOS (you mentioned about it on the private message with me but why not here? It's not like we won't try and help you if we know that) ....
They applied some cpu-tweaks without any prior knowledge about what they can cause.
I just run the command top and saw "system_server" takes 12-15% and "logd" takes 9-11% of the CPU Load.
I couldn't find any working method to fix this issue in the web.
Post automatically merged:

After a lot of testings I found the reason. High CPU load was because CZ Filemanager was not installed.
I will start a new thread for the new problem resulting from this.

Thread can be closed.
 
Last edited:

Similar threads

Similar threads

Get Connected

Discord Server

New Threads

Latest From Blog

Top